Sucede que al actualizar se nos pide que actualizemos primero pacman a su nueva version 4.0.2-1:

:: Los siguientes paquetes deben actualizarse primero:
pacman
:: ¿Desea cancelar la operación actual
:: y actualizar estos paquetes ahora? [S/n]

Pero al hacerlo hay un error que dice:

error: error al preparar la transacción (no se pudieron satisfacer las dependencias)
:: gcc: necesita gcc-libs=4.7.0-3

Esto se resuelve de la manera mas simple, haciendo que pacman reinstale pacman:

[root@delly lucain]# pacman -S pacman

Al terminar nos dara este mensaje:

Run `pacman-key --init` to set up your pacman keyring.

Que es la forma de manejar las llaves gpg de esta nueva version de pacman, que es material para el siguiente post